Quantcast
Channel: CSDN博客推荐文章
Viewing all articles
Browse latest Browse all 35570

hdu2029——Palindromes_easy version

$
0
0

原题:

 

Problem Description
  “回文串”是一个正读和反读都一样的字符串,比如“level”或者“noon”等等就是回文串。请写一个程序判断读入的字符串是否是“回文”。

 

 

Input
  输入包含多个测试实例,输入数据的第一行是一个正整数n,表示测试实例的个数,后面紧跟着是n个字符串。

 

 

Output
  如果一个字符串是回文串,则输出"yes",否则输出"no".

 

 

Sample Input
  4
level
abcde
noon
haha

 

 

Sample Output
  yes
no
yes
no

 

分析:

掌握字符串的常用函数。该题有多种解法!

原码:

#include <stdio.h>
#include <string.h>

int main()
{
    int n;
    char s[1024];
    char t[1024];

    scanf("%d%*c", &n);
    
    while (n--)
    {
        gets(s);
        strcpy(t, s);
        strrev(s);
        puts(strcmp(t, s) ? "no" : "yes");
    }

    return 0;
}


 

作者:bingsanchun1 发表于2013-3-24 0:21:46 原文链接
阅读:108 评论:0 查看评论

Viewing all articles
Browse latest Browse all 35570

Trending Articles



<script src="https://jsc.adskeeper.com/r/s/rssing.com.1596347.js" async> </script>