Quantcast
Channel: CSDN博客推荐文章
Viewing all articles
Browse latest Browse all 35570

hdu 1161 Eddy's mistakes

$
0
0

Eddy's mistakes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6152    Accepted Submission(s): 3491


Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.
 

Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
 

Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
 

Sample Input
weLcOmE tO HDOj Acm 2005!
 

Sample Output
welcome to hdoj acm 2005!
 

Author
eddy
 

Recommend
JGShining
 
 
#include <iostream>
#include <string>
using namespace std;
int main()
{
	string s;
	char ss[1005];
	int i,j;
	while (gets(ss)!=NULL)
	{
		s=ss;
		for (i=0;s[i]!='\0';i++)
		{
			if (s[i]>='A'&&s[i]<='Z')
			{
				s[i]+=32;
			}
		}
		cout<<s<<endl;
	}
	return 0;
}

作者:u010405898 发表于2013-8-22 14:24:45 原文链接
阅读:21 评论:0 查看评论

Viewing all articles
Browse latest Browse all 35570

Trending Articles